Open Threat Exchange Portal Service Degradation
Incident Report for Open Threat Exchange
Resolved
The incident has been resolved
Posted 15 days ago. Mar 04, 2019 - 16:29 UTC
Investigating
We are currently investigating the issue
Posted 15 days ago. Mar 04, 2019 - 16:06 UTC
This incident affected: OTX API and OTX Website.