Open Threat Exchange Portal and API Performance Degradation
Incident Report for Open Threat Exchange
Resolved
OTX is all better. Let’s be secure out there!
Posted 10 months ago. Feb 02, 2018 - 02:20 UTC
Monitoring
We have taken corrective action and are seeing performance improve as the backlog of requests clears. We will update again wil everything is normal.
Posted 10 months ago. Feb 02, 2018 - 01:58 UTC
Investigating
We are experiencing performance problems on the OTX API and Portal leading to long response times and/or timeouts when accessing the API or browsing the Web site. Our engineering team is working to restore service. We will update you when the issue is resolved.
Posted 10 months ago. Feb 02, 2018 - 00:30 UTC