Partial Outage
Incident Report for Open Threat Exchange
Resolved
OTX is back to performing well again. Thank you for your patience.
Posted 3 months ago. Jun 16, 2017 - 16:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Jun 16, 2017 - 13:00 UTC
Investigating
We are investigating an issue causing degraded performance on OTX.
Posted 3 months ago. Jun 16, 2017 - 12:15 UTC