Open Threat Exchange Performance Degradation
Incident Report for Open Threat Exchange
Resolved
OTX performance has returned to normal. Enjoy! Alienvault wishes you a threat-free day.
Posted 4 months ago. Jul 11, 2017 - 20:59 UTC
Investigating
OTX is having some performance issues at the moment, our engineering team is working on resolving the issue.
Posted 4 months ago. Jul 11, 2017 - 19:49 UTC